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ACHIZITIE DE SEMNALE BIOLOGICE 
 CU SISTEMUL BIODAQ 

INTRODUCERE 
Aparatele BioDAQ reprezintă sisteme de achiziţie ale semnalelor biologige, 
prezente în două versiuni constructive: student şi expert. Aceste aparate pot 
măsura următoarele tipuri de semnale: 

- sfigmograma manometrică (cu ajutorul unui detector de 
presiune), 

- sfigmograma optica (cu ajutorul unui detector de puls în 
infraroşu), 

- semnale ECG/EMG folosind electrozi standard pentru 1 
derivaţie, 

- semnale EEG- doar versiunea expert a aparatului, 
- semnal provenit de la un alt aparat cu domeniul de măsură + 

2048 mV.  

BIODAQ–STUDENT 

Aparatele BioDAQ-student sunt proiectate pentru culegerea unor semnale 
biologice 'in vivo' în timpul lucrărilor practice ale studenţilor. Aparatul este 
compus din module de amplificare pentru diferitele tipuri de semnale, 
conţine un convertor analog-digital pe 12 biţi şi un microcontroler care este 
răspunzător de comunicaţia cu un calculator pe port serial.  

Este un sistem de achiziţie pe 8 canale, selectabile din software, după 
cum urmează: 

- 1 ieşirea directă a amplificatorului ECG  
- 2 ieşirea filtrată (opreşte banda pe 50 Hz) a amplificatorului ECG, 
- 3 ieşirea filtrată (FOB 50Hz şi FTJ 35 Hz) a amplificatorului ECG 

(standard pentru înregistratoarele ECG comerciale), 
- 4 ieşire RMS (root mean square) din amplificatorul ECG (util pentru 

înregistrările EMG, deoarece acesta este un semnal proporţional cu forţa de 
contracţie musculară ), 
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- 5 puls-optic (Fotopletismografie - metoda ce permite detecţia fluxului 
sanguin la nivelul extremităţilor prin detecţia schimbării transparenţei 
ţesuturilor pentru lumina infraroşie), 

- 6 presiune manometrică absolută, 
- 7 puls manometric, 
- 8 intrare auxiliară. 

Sistemul respectă în totalitate prevederile clasei III de electroprotecţie, 
beneficiind de alimentare de joasă tensiune din baterii de 9 V şi fiind izolat 
galvanic faţă de calculator cu optocuploare de tip HCPL2630 la nivelul 
interfeţei seriale (5000 V DC). 

Instalarea aparatului: 
Pe carcasa aparatului se găsesc 3 sau 4 mufe, în funcţie de model, la 

care se conectează electrozii şi traductorii necesari. Pe prima mufă din 
stânga se conectează traductorul fotopletismografic, iar pe cea de a doua 
electrozii ECG/EMG (aparatul fiind cu mufele înspre noi şi cu faţa argintie 
metalică în sus). 
 Aparatul se conectează prin intermediul conectorului RJ-11 la unul 
din porturile seriale libere ale calculatorului cu ajutorul cablului anexat şi a 
unuia dintre conectoarele incluse ( DB25 sau DB9 ). 

Software: 

Întregul sistem de achiziţie este comandat de către un software specializat, 
ce permite selecţia intrărilor, afişarea semnalului, precum şi filtrarea digitală 
a acestuia. Se rulează efectuând un dublu clic pe pictograma „BioDAQ” de 
pe Desktop.  

După deschiderea ferestrei programului, este necesar să testăm dacă 
legătura cu computerul este corectă, apelând din meniul aplicaţiei “File -> 
Properties -> Comm settings”. 
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Se va deschide o casetă de dialog ce oferă următoarele opţiuni: 

- Alegerea portului dorit (COM1..COM9) . De obicei se foloseşte portul 
1 sau 2. 

- Setarea vitezei de comunicaţie (Baud Rate =57600). Comunicaţia cu 
calculatorul se realizează pe interfaţa serială folosind o viteză de 57600 
baud, 8 biţi de date, 1 bit de start, 1 bit de stop, adică 5760 bytes pe secundă  
(valori de 8 biţi pe secundă ). Mai exact 1 bit de start + 8 biţi date + 1 bit de 
stop = 10 biţi, rezultă 57600/10 = 5760 valori pe secundă). 

- Testarea portului cu ajutorul butonului ‘TxHEX’. 
- Setarea pinilor RTS/DTR :  

- pentru porturi seriale obişnuite : 
  RTS ON DTR OF 
- pentru porturi pe USB: 
 RTS OFF DTR ON 

- Setarea dispozitivului conectat (DEVICE):  
• 2 pentru BioDAQ – student şi  
• 3 pentru BioDAQ – expert. 

- Redeschiderea portului după eventualele modificări (REOPEN). 

 

Dacă apare mesajul 'COM open error' atunci portul sau nu este instalat 
sau este ocupat de către alt program (sau este blocat de o altă instanţă a 
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programului BioDAQ); în acest caz închideţi programul care ocupă portul şi 
verificaţi în meniul Windows: Start -> Settings -> Control Panel -> System -

> COM & LPT existenţa portului ales. Dacă aţi efectuat setările corect şi 
aparatul este conectat la portul ales la apăsarea butonului  'REOPEN' se va 
aprinde LED- ul verde, iar LED- ul galben va clipi până la primirea primei 

comenzi. Apăsaţi tasta ‘TxHEX’ care va transmite o comandă în urma 
căreia LED- ul galben se stinge, se aprind 1- 2 LED- uri verzi dintre cele 8 

care desemnează canalele selectate, iar în câmpul din dreptul ‘RxHEX’ 
trebuie să apară un şir de caractere care reprezintă mesajele recepţionate. 

Realizarea unei achiziţii de semnal presupune parcurgerea în 
continuare a următorilor trei paşi: configurarea canalelor, iniţierea unei noi 
măsurători şi achiziţia propriu-zisă. 

ECG 

1. Se conectează cablul ECG la cea de a doua mufă din stânga, prin 
apăsarea uşoară a jack-ului în orificiul prevăzut pentru acesta, până la 
simţirea unui uşor clic. 

2. Se conectează electrozii ECG la cablu prin folosirea clemelor crocodil. 
Cei doi electrozi activi se conectează la cele două cleme marcate de o 
învelitoare roşie, iar electrodul indiferent (masa) se conectează la cablul 
subţire, distingibil prin învelitoarea neagră la nivelul clemei. 

3. Se configurează canalele prin secvenţa de meniu “File -> Properties -> 
Channels” alegând activarea canalelor 1, 2 şi 3 (cele 3 perechi de check-
box- uri din stânga listei de canale), confirmând cu OK 
configurarea.
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4. Se maximizează fereastra aplicaţiei, apoi se iniţiază o nouă secvenţă de 
măsurători alegând “File -> New -> Measuring” din meniu.  

 

Pe ecran apar trei ferestre în care va apare mai târziu semnalul achiziţionat. 
5. Se montează electrozii pe "pacient", cei doi electrozi activi la nivelul 

gâtului mâinilor iar electrodul indiferent preferabil la nivelul piciorului 
drept (având grijă de a nu smulge cablul din mufă, clemele de pe 
electrozi, aparatul de pe masă, subiectul de pe scaun etc.). Pentru a 
asigura un bun contact cu electrozii, se foloseşte puţin gel conductor . 

6. Se porneşte măsurătoarea apelând din meniu “Measure -> Start” sau 
butonul corespunzător din dreapta ferestrei aplicaţiei. 

  

În cele trei ferestre se vor putea observa semnalele achiziţionate defilând 
pe ecran. Ţineţi cont ca semnalul este destul de mic, urmând a fi 
prelucrat ulterior. În mod normal se pot observa complexe QRS de circa 
3 mm. 

7. În momentul obţinerii unui ecran cu semnale satisfăcătoare, se opreşte 
achiziţia apelând “Measure -> Stop” din meniul programului sau butonul 
corespunzător şi se trece la prelucrarea acestuia (vezi Prelucrarea 
semnalelor). 
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EMG 

1. Se păstrează cablul ECG conectat la cea de a doua mufă din stânga. 
2. Se îndepărtează cei doi electrozi activi folosiţi la culegerea semnalului 
ECG, electrodul pasiv rămânând fixat pe piciorul drept. Se aplică pe faţa 
internă a antebraţului, în treimea medie, doi electrozi autoadezivi, pe care se 
vor fixa clemele marcate cu învelitoare roşie ale cablului. Este bine ca 
electrozii să fie plasaţi în dreptul unui muşchi flexor al mâinii, la distanţă de 
2-3 cm unul de altul; ulterior, după culegerea semnalului, se vor încerca şi 
alte grupe musculare de la acest nivel.  
3. Se configurează canalele prin secvenţa de meniu “File -> Properties -> 
Channels” alegând activarea canalului 4 (perechea de check-box- uri din 
stânga listei de canale), confirmând cu OK configurarea. 
4. Se iniţiază o noua secvenţă de măsurători alegând “File -> New -> 
Measuring” din meniu. Pe ecran se deschide o fereastră în care va apare mai 
târziu semnalul achiziţionat. 
5. Se porneşte măsurătoarea apelând din meniu “Measure -> Start”. Iniţial 
se obţine o linie izoelectrică, corespunzător stării de repaus. La flectarea 
rapidă a câte unui deget se obţin succesiuni de unde pozitive şi negative, a 
căror amplitudine variază proporţional cu amplitudinea contracţiei izotonice, 
respectiv cu forţa contracţiei izometrice. Semnalul cel mai amplu se obţine 
la flectarea degetului corespunzător muşchiului în dreptul căruia au fost 
amplasaţi electrozii de culegere. 
6. În momentul obţinerii unui ecran cu semnale satisfăcătoare, se opreşte 
achiziţia apelând “Measure -> Stop” din meniul programului şi se trece la 
prelucrarea acestuia. 

 



Achizitie de semnale cu BioDAQ 
  

 103 

Fotopletismografie 

1. Se conectează traductorul pletismografic la prima mufă din stânga, 
prin apăsarea uşoară a jack- ului în orificiul prevăzut pentru acesta, până la 
simţirea unui uşor clic. 
2. Se configurează canalul prin secvenţa de meniu “File -> Properties -> 
Channels” alegând activarea canalului 5 (perechea de check-box- uri din 
stânga listei de canale), confirmând cu OK configurarea. 
3. Se iniţiază o nouă secvenţă de măsurători alegând “File -> New -> 
Measuring” din meniu. 
Pe ecran apare o fereastră în care va apare mai târziu semnalul achiziţionat. 
4. Se montează traductorul pe indexul uneia din mâini (având grijă de a 
nu smulge cablul…). 
5. Se porneşte măsurătoarea apelând din meniu “Measure -> Start”, pe 
ecran observându-se semnalul achiziţionat. Semnalul apare centrat, cu 
variaţii sincrone cu pulsul, amplitudinea acestora fiind de cca. 2 cm. 
6. În momentul obţinerii unui ecran cu semnal satisfăcător, se opreşte 
achiziţia apelând “Measure -> Stop” din meniul programului şi se trece la 
prelucrarea acestuia. 
 
Prelucrarea semnalelor 

 Programul permite prelucrarea semnalelor obţinute, funcţiile de bază 
fiind zoom (mărire), filtrare digitală şi  calcularea spectrului prin FFT. 

Funcţia Zoom 
 Această funcţie permite selectarea unei porţiuni de interes din semnal 
şi mărirea acestuia la dimensiunea ferestrei. Acest fapt permite observarea 
detaliilor din porţiunea de semnal selectată. 

 Se începe cu stabilirea începutului zonei (colţul stânga sus) prin 
punerea cursorului în regiunea dorită. Se apasă butonul stâng al mouse-ului 
şi se ţine apăsat. Se continuă selecţia prin mişcarea  mouse- ului până la 
atingerea colţului dreapta jos a porţiunii dorite, eliberând apoi butonul stâng. 
Porţiunea selectată apare evidenţiată prin negativarea imaginii. În momentul 
eliberării butonului, porţiunea dorită va fi extinsă pe întreaga fereastră. 
Pentru a ajunge în situaţia anterioară funcţiei de zoom, se pune cursorul pe 
fereastra dorită şi se apasă butonul din dreapta al mouse- ului. 
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Filtrarea digitală 
Funcţia de filtrare digitală  se apelează prin meniu, alegând în prima 

etapă tipul de filtru (View -> Set Filter) cu variantele trece sus (high pass), 
trece jos (low pass), trece bandă (band pass) şi opreşte bandă (band stop). 
De exemplu, pentru suprimarea bruiajului dat de reţeaua de alimentare se 
alege un filtru opreşte bandă, cu limitele 48 – 50 Hz şi 11 elemente de 
filtrare. Acceptarea parametrilor se face prin funcţia EXIT. 

 

Filtrarea se aplică automat pe fereastra activă, pentru dezactivarea ei 
fiind necesară apăsarea butonului de filtrare (ultimul buton din dreapta 
ferestrei programului). Se poate reactiva printr-o nouă apăsare a acestuia. 

Filtrarea se poate aplica individual pe toate ferestrele de semnal, 
inclusiv pe spectru. 

Spectrul de putere 
 Alegând funcţia spectru (FFT) prin apăsarea butonului corespunzător 
(penultimul din şirul de butoane din dreapta ferestrei program) se obţine 
calcularea spectrului de putere al semnalului achiziţionat. 

 Funcţia de zoom şi de filtrare sunt active şi în acest caz, observându-se 
foarte uşor funcţia de filtrare (dispariţia unui eventual vârf de semnal pe 50 
Hz la aplicarea filtrului opreşte bandă definit mai sus). 

 Rezoluţia spectrală depinzând de durata epocii de achiziţie, ea scade 
dacă se achiziţionează mai multe semnale deodată. 
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Observaţii 

Achiziţiile se pot repeta ori de câte ori e nevoie, prin reapelarea funcţiei 
Measure -> Start, iar dacă se doreşte o alta configurare, se reia algoritmul de 
la început, inclusiv configurarea canalelor. Ţineţi cont că setările de zoom se 
păstrează, deci este nevoie să  ieşiţi din funcţia zoom pentru a vedea tot 
traseul de semnal. În cazul în care nu reuşiţi, apelaţi “File -> New -> 
Measurement”, pentru reiniţializarea ferestrelor şi reluarea achiziţiei. 

În cazul în care programul refuză să mai achiziţioneze semnale, 
problema se rezolvă prin ieşire din program şi repornirea acestuia (se poate 
întâmpla după reconfigurări şi zoom-uri repetate). 

De ţinut cont că nu puteţi părăsi programul fără a opri achiziţia, deci 
dacă programul nu poate fi oprit, verificaţi dacă achiziţia nu este activă 
(executaţi Measure -> Stop) şi reâncercaţi să-l închideţi. 

În cazul în care nu reuşiţi să convingeţi aparatul să funcţioneze, apelaţi 
la cadrul didactic. 

BIODAQ – EXPERT 

Aparatul BioDAQ-expert este proiectat pentru culegerea unor semnale 
biologice de la cazuri patologice reale din spitale. De aceea, acesta este un 
aparat de sine stătător care poate înregistra şi stoca semnalele în memoria 
internă. Semnalele pot fi ulterior vizualizate şi prelucrate cu ajutorul 
programului BioDAQ care rulează pe un calculator compatibil PC. Aparatul 
este compus din module de amplificare pentru diferitele tipuri de semnale, 
conţine un convertor analog-digital pe 12 biţi şi un microprocesor pe 16 biţi. 
Pentru efectuarea setărilor, respectiv verificarea calităţii semnalului aparatul 
este dotat cu un ecran LCD alb-negru de 320x240 puncte (1/4 VGA).  

Aparatul  BioDAQ-expert este alimentat de la un acumulator intern  şi 
este izolat din punct de vedere galvanic de calculatorul la care se 
conectează, deci este un aparat cu masa flotantă din motive de 
electrosecuritate. Canalele de măsură sunt următoarele şi pot fi selectate 
doar în perechi: 

- 1 - canal pentru sfigmograma optică, 
- 2 - canal pentru sfigmograma manometrică, 
- 3-8 - canale dotate cu amplificatoare de semnal biologic.  
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 Canalele dotate cu amplificatoare de semnal biologic dispun de o serie 
de setări cu ajutorul cărora se pot optimiza proprietăţile acestora pentru un 
anumit tip de semnal (EEG/ECG/EMG): 

- amplificare reglabilă în 4 trepte (Gain) : 500,1000,2000,5000; 
- filtru pentru brumul de reţea pe 50Hz  (Notch): 40 db la 50 Hz; 
- filtru trece jos, în 4 trepte (LPF): OFF, 35Hz ,70Hz , 140Hz; 
- ieşire prelucrată RMS (pentru culegerea EMG).   

Aparatul este dotat cu 3 LED - uri de control: verde, galben şi roşu, 
precum şi cu patru butoane de comandă, cu diferite semnificaţii în funcţie de 
starea aparatului (măsurare, înregistrare, replay, meniu): 1- albastru, 2- roşu, 
3- alb, 4- alb . 

Instalarea aparatului 

Aparatul BioDAQ-expert este alimentat prin intermediul unui adaptor 
de reţea de 15V DC pentru încărcare (15 h) ce se conectează la mufa situată 
pe faţa laterală stângă a carcasei.  

Atenţie! În timpul culegerii biosemnalelor aparatul NU trebuie să fie 
conectat la sursa de alimentare; încărcarea acumulatorului intern se va face 
doar cu aparatul în stare de repaus. 

Tot pe faţa laterală stângă a carcasei se află conectorul RJ-11 pentru 
legătura cu computerul pe portul serial şi un întrerupător ON/OFF. Când 
aparatul nu este folosit, întrerupătorul va fi pus pe poziţia OFF pentru a 
prevenii descărcarea acumulatorului. La pornirea aparatului se va aprinde 
Led - ul galben timp de 5 secunde, apoi Led – ul verde, aparatul rămânând 
în stare de repaus  până la primirea unei comenzi. Pe faţa laterală dreaptă a 
carcasei se află conectorul tubului pentru sfigmograma manometrică şi în 
imediata sa vecinătate, mufa pentru traductorul fotopletismografic. Pe latura 
posterioară se află 17 mufe grupate (4x3 + 2x2 + 1). Pe prima grupă din 
dreapta se conectează electrozii ECG/EMG respectând codurile de culoare 
corespunzătoare cablului ( roşu, negru, albastru). Pe ultima mufă din stânga 
se va conecta cablul de masă.  

Realizarea unei achiziţii de semnal se poate face în două moduri: 

1. Off line - cu aparatul la patul pacientului, caz în care setările se 
efectuează din meniul afişat pe ecranul dispozitivului de achiziţie. 
Navigarea prin meniu se realizează apăsând succesiv butonul 3 (primul 



Achizitie de semnale cu BioDAQ 
  

 107 

buton alb, de sus în jos) iar schimbarea setării se obţine prin apăsarea 
butonului 4 (al doilea buton alb). În cazul achiziţiei Off Line, dacă s-a 
procedat la memorarea unor semnale (record), acestea pot fi transferate pe 
calculator pentru prelucrare. 

2. On line - cu aparatul conectat la PC pe portul serial, caz în care 
setările şi toate comenzile se execută din meniul aplicaţiei BioDAQ ce 
rulează pe computer (asemănător cu modul de operare al dispozitivului 
BioDAQ - student).  

ÎN ACEASTĂ LECŢIE AŢI ÎNVĂŢAT: 

• Să instalaţi sistemul de achiziţie de semnale biologice BioDAQ-
student. 

• Să configuraţi componentele hardware şi software ale sistemului de 
achiziţie. 

• Să înregistraţi semnale ECG, EMG şi sfigmograme cu ajutorul 
dispozitivului BioDAQ. 

• Să prelucraţi semnalele înregistrate prin funcţiile de zoom, filtrare 
digitală şi să calculaţi spectrul de putere al semnalului achiziţionat. 

• În partea demo aţi observat modul de lucru cu sistemul BioDAQ-
expert, achiziţia semnalelor şi transferul acestora pe calculator pentru 
prelucrare. 


